Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with my Kanger t3'd
#1
I have a clear Kanger T3'D tanks with a replaceable coil. I opened it to refill the ejuice a couple of days ago, as I have always done.

Now, I cannot get the the bottom ring, that holds the coil in place, screwed back on. It won't screw down nice and flush the way it has before, meaning the coil won't heat as it keeps the battery part from making contact with the heating element...at least I think that is what it is called.

Is there a way to get this part screwed back down or will I need to buy new parts?
#2
I haven't used that particular Kanger tank before but just taking a stab at it... could the threads on the tank possibly be stripped causing the base to just not want to thread correctly?

If this is the case, it may be best to just buy a new tank. I know that wasn't much help but I thought I'd give my two cents Smile
#3
cerebral79 Wrote:I haven't used that particular Kanger tank before but just taking a stab at it... could the threads on the tank possibly be stripped causing the base to just not want to thread correctly?

If this is the case, it may be best to just buy a new tank. I know that wasn't much help but I thought I'd give my two cents Smile

Thanks so very much for the answer. As far as I can tell the threads are fine, so I'm taking the tanks and battery with me to the store whew I bought them. The man who sold me the tank was very helpful with a previous issue so he might be able to help me with this new glitch.

In the end, I might just buy a new tank

Thanks!
#4
Update:

I went to the shop where I bought my kanger and the salesperson pointed out the second set of threads that I had not seen. Once I saw those and screwed the tanks innards down, everything went back into place!

All fixed!
  


Forum Jump:


Users browsing this thread:
1 Guest(s)

Problems with my Kanger t3'd00